首页 > Linux, Mysql, 项目实施 > libaio.so.1()(64bit) is needed by MySQL-server
201210月25

libaio.so.1()(64bit) is needed by MySQL-server

错误信息

Linux CenterOs 64位中安装 MySQL-server-5.5.25a-1.rhel5.x86_64.rpm 出现以下错误
[root@localhost upload]# rpm -ivh MySQL-server-5.5.25a-1.rhel5.x86_64.rpm
error: Failed dependencies:
libaio.so.1()(64bit) is needed by MySQL-server-5.5.25a-1.rhel5.x86_64
libaio.so.1(LIBAIO_0.1)(64bit) is needed by MySQL-server-5.5.25a-1.rhel5.x86_64
libaio.so.1(LIBAIO_0.4)(64bit) is needed by MySQL-server-5.5.25a-1.rhel5.x86_64
从以上错误信息可以看出是因为缺少库libaio,所以需要安装libaio

安装libaio-0.3.107-10.el6.x86_64.rpm

下载地址:
http://mirror.centos.org/centos/6/os/x86_64/Packages/libaio-0.3.107-10.el6.x86_64.rpm
安装完成后,即可成功安装MySQL-server-5.5.25a-1.rhel5.x86_64.rpm
按照上面的方法,安装后之后如果还是存在问题,你可以在文章后面进行留言说明

文章作者: iitshare
本文地址:http://www.iitshare.com/libaio-so-164bit-is-needed-by-mysql-server.html
版权所有 © 转载时必须以链接形式注明作者和原始出处!

更多

23 Responses to “libaio.so.1()(64bit) is needed by MySQL-server”

  1. #1 郭文鑫 回复 | 引用 Post:2013-05-16 17:48
  2. #4 叶子 回复 | 引用 Post:2013-05-20 10:40

    [root@dbserver local]# rpm -ivh libaio-0.3.107-10.el6.x86_64.rpm
    warning: libaio-0.3.107-10.el6.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID c105b9de: NOKEY
    Preparing… ########################################### [100%]
    package libaio-0.3.107-10.el6.x86_64 is already installed
    file /lib64/libaio.so.1.0.0 from install of libaio-0.3.107-10.el6.x86_64 conflicts with file from package libaio-0.3.107-10.el6.x86_64
    file /lib64/libaio.so.1.0.1 from install of libaio-0.3.107-10.el6.x86_64 conflicts with file from package libaio-0.3.107-10.el6.x86_64

  3. #5 叶子 回复 | 引用 Post:2013-05-20 10:43

    我们有安装过,为什么它说我安装了,但是回去安装mysql:

  4. #6 叶子 回复 | 引用 Post:2013-05-20 10:43

    [root@dbserver local]# cd MySQL/
    [root@dbserver MySQL]# ls
    MySQL-server-5.6.11-2.linux_glibc2.5.i386.rpm
    [root@dbserver MySQL]# rpm -ivh MySQL-server-5.6.11-2.linux_glibc2.5.i386.rpm
    error: Failed dependencies:
    libaio.so.1 is needed by MySQL-server-5.6.11-2.linux_glibc2.5.i386
    libaio.so.1(LIBAIO_0.1) is needed by MySQL-server-5.6.11-2.linux_glibc2.5.i386
    libaio.so.1(LIBAIO_0.4) is needed by MySQL-server-5.6.11-2.linux_glibc2.5.i386
    libstdc++.so.6 is needed by MySQL-server-5.6.11-2.linux_glibc2.5.i386
    libstdc++.so.6(CXXABI_1.3) is needed by MySQL-server-5.6.11-2.linux_glibc2.5.i386
    libstdc++.so.6(GLIBCXX_3.4) is needed by MySQL-server-5.6.11-2.linux_glibc2.5.i386
    MySQL conflicts with mysql-5.1.52-1.el6_0.1.x86_64
    MySQL-server conflicts with mysql-server-5.1.52-1.el6_0.1.x86_64

    • #7 iitshare 回复 | 引用 Post:2013-05-21 21:19

      按照上面的方法解决就行

  5. #8 叶子 回复 | 引用 Post:2013-05-20 10:44

    我没有安装过,为什么它说我安装了,但是回去安装mysql:

    • #9 iitshare 回复 | 引用 Post:2013-05-21 21:18

      应该是系统默认自带了,你先把自带的卸载了,再安装

  6. #10 竹子 回复 | 引用 Post:2013-06-01 19:03

    安装后出现
    [root@AY1305271500337110d8Z soft]# rpm -ivh libaio-0.3.107-10.el6.x86_64.rpm
    warning: libaio-0.3.107-10.el6.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID c105b9de
    error: Failed dependencies:
    rpmlib(FileDigests) <= 4.6.0-1 is needed by libaio-0.3.107-10.el6.x86_64
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by libaio-0.3.107-10.el6.x86_64

  7. #12 young 回复 | 引用 Post:2013-07-23 15:45

    请问32位的在哪下载呢

    • #13 iitshare 回复 | 引用 Post:2013-07-23 22:17

      在以上网站也可以进行下载,地址是:http://mirror.centos.org/centos/6/os/i386/Packages/libaio-0.3.107-10.el6.i686.rpm

  8. #14 frank 回复 | 引用 Post:2013-12-22 18:45

    [root@localhost mysql]# rpm -ivh MySQL-server-5.6.15-1.el6.i686.rpm
    error: Failed dependencies:
    /usr/bin/perl is needed by MySQL-server-5.6.15-1.el6.i686
    libaio.so.1 is needed by MySQL-server-5.6.15-1.el6.i686
    libaio.so.1(LIBAIO_0.1) is needed by MySQL-server-5.6.15-1.el6.i686
    libaio.so.1(LIBAIO_0.4) is needed by MySQL-server-5.6.15-1.el6.i686
    libc.so.6 is needed by MySQL-server-5.6.15-1.el6.i686
    =====================

    rpm -ivh libaio-0.3.107-10.el6.x86_64.rpm
    warning: libaio-0.3.107-10.el6.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID c105b9de: NOKEY
    Preparing… ########################################### [100%]
    1:libaio ########################################### [100%]

    libaio已经安装成功了,为什么还是提示那个呢

  9. #15 小怪兽 回复 | 引用 Post:2014-01-20 16:31

    Preparing… ########################################### [100%]
    package libaio-0.3.107-10.el6.x86_64 is intended for a x86_64 architecture
    package libaio-0.3.107-10.el6.x86_64 is already installed
    安装成功了,还是有提示信息
    error: Failed dependencies:
    libaio.so.1()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libaio.so.1(LIBAIO_0.1)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libaio.so.1(LIBAIO_0.4)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libc.so.6()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libc.so.6(GLIBC_2.3)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libcrypt.so.1()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libcrypt.so.1(GLIBC_2.2.5)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libdl.so.2()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libdl.so.2(GLIBC_2.2.5)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libm.so.6()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libm.so.6(GLIBC_2.2.5)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libpthread.so.0()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    librt.so.1()(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64
    librt.so.1(GLIBC_2.2.5)(64bit) is needed by MySQL-server-5.5.20-1.linux2.6.x86_64

    • #16 夏未眠 回复 | 引用 Post:2014-04-17 09:34

      14楼的小怪兽,请问你这个问题解决了没啊?我也遇到了一模一样的问题

      • #17 iitshare 回复 | 引用 Post:2014-04-19 11:17

        安装libaio-0.3.107-10.el6.x86_64.rpm类库就行

  10. #18 搜索引擎收录 回复 | 引用 Post:2015-01-19 15:50

    啊哈,真巧看到这个,关注关注。

  11. #19 过路人 回复 | 引用 Post:2015-07-21 16:52

    大神请求帮忙
    Error: Package: 1:R-core-3.0.1-2.el5.x86_64 (puias-server)
    Requires: libtcl8.4.so()(64bit)
    Error: Package: 1:R-core-3.0.1-2.el5.x86_64 (puias-server)
    Requires: libtk8.4.so()(64bit)

  12. #20 安心 回复 | 引用 Post:2015-09-28 14:08

    我也碰到同样问题,请问谁来解答一下

  13. #21 安心 回复 | 引用 Post:2015-09-28 14:15

    我自己解决了,发现安装libaio-0.3.107-10.el6.x86_64.rpm不行,安装下面这个就好使了libaio-0.3.107-10.el6.i686.rpm
    也许操作系统不是64位的吧

  14. #22 还是不行 回复 | 引用 Post:2015-11-18 17:17

    还是不行啊,我libaio两个都试了

发表评论